XQuartz Mountain Lion “Color Depth” Bug mit RDesktop

Da hat mich seit einigen Tagen ein ziemlich fieser Bug aufgeregt… vieleicht habt ihr es auch schon bemerkt oder fallt irgendwann noch darüber. Wie ihr sicher wisst, gibt es keinen X11 Server mehr von Apple, man muss unter Mountain Lion auf das freie Gegenstück XQuartz zurückgreifen. Gesagt getan, die aktuelle RC (2) runtergeladen, installiert und gleich einen Testlauf gestartet. Ich benutze über ein FirmenVPN “rdesktop” unter Linux um von der Ferne einen Windows Terminalserver anzuzeigen. Was passiert? Klar, nicht das gewohnte sondern das Fenster war etwas wirr…
Das Bild ist total verzogen, die Farben etwas auf Drogen und an ein gezieltes klicken ist nicht mal im Ansatz zu denken. Also was tun? Ich hab erst mal die XQuartz Version in Verdacht gehabt und anstelle der Development Version auf die Stable runter installiert. Keine Besserung, selbes Problem. Also eine andere RDesktop Version (Aktuell ist bei uns 1.7.1) getestet. Auch keine Besserung. Dann hab ich noch eine ganz alte, 1.4.x, gefunden und siehe da, Fenster war zwar winzig da keine Parameter mitgegeben aber es ging. Moment mal, keine Parameter mitgegeben? Das Problem war also in den Parametern. Gesucht und gefunden. XQuartz hat scheinbar ein Problem mit der Farbtiefe bei RDesktop. Diese ist bei uns per Default auf “-a 16” also 16 Bit Farbtiefe gestellt. Mag XQuartz bei RDesktop, egal welche Version (!) überhaupt nicht und verweigert seinen Dienst mit dem hier gezeigten Bild.

  1. Hab das gleiche Problem.

    Schon ein Workaround gefunden?

    MFG

Leave a Comment


NOTE - You can use these HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">

This site uses Akismet to reduce spam. Learn how your comment data is processed.